Changes in directory llvm/include/llvm/Support:
PatternMatch.h updated: 1.19 -> 1.20 --- Log message: Rename Value::getValueType to getValueID, to avoid confusion with other things named getValueType. --- Diffs of the changes: (+3 -3) PatternMatch.h | 6 +++--- 1 files changed, 3 insertions(+), 3 deletions(-) Index: llvm/include/llvm/Support/PatternMatch.h diff -u llvm/include/llvm/Support/PatternMatch.h:1.19 llvm/include/llvm/Support/PatternMatch.h:1.20 --- llvm/include/llvm/Support/PatternMatch.h:1.19 Mon Feb 12 18:37:50 2007 +++ llvm/include/llvm/Support/PatternMatch.h Fri Apr 13 13:12:09 2007 @@ -81,7 +81,7 @@ template<typename OpTy> bool match(OpTy *V) { - if (V->getValueType() == Value::InstructionVal + Opcode) { + if (V->getValueID() == Value::InstructionVal + Opcode) { ConcreteTy *I = cast<ConcreteTy>(V); return I->getOpcode() == Opcode && L.match(I->getOperand(0)) && R.match(I->getOperand(1)); @@ -195,8 +195,8 @@ template<typename OpTy> bool match(OpTy *V) { - if (V->getValueType() == Value::InstructionVal + Instruction::LShr || - V->getValueType() == Value::InstructionVal + Instruction::AShr) { + if (V->getValueID() == Value::InstructionVal + Instruction::LShr || + V->getValueID() == Value::InstructionVal + Instruction::AShr) { ConcreteTy *I = cast<ConcreteTy>(V); return (I->getOpcode() == Instruction::AShr || I->getOpcode() == Instruction::LShr) && _______________________________________________ llvm-commits mailing list [EMAIL PROTECTED] http://lists.cs.uiuc.edu/mailman/listinfo/llvm-commits