Issue |
133505
|
Summary |
[libc] Clean up copt naming
|
Labels |
good first issue,
libc
|
Assignees |
|
Reporter |
michaelrj-google
|
Our code style document says all our compile flags set by the build system should start `LIBC_COPT_` but not all of them do. We should update them to fit our naming scheme.
Steps to fix:
1. go through the flags in [`config.json`](https://github.com/llvm/llvm-project/blob/827f2ad64394bdcafabc58133c4b8258f728763c/libc/config/config.json)
2. For each flag, check what copt it defines
3. If that copt doesn't start with `LIBC_COPT_`, rename it so it does.
4. Make sure the flag is renamed everywhere it's used in code, cmake, and bazel.
_______________________________________________
llvm-bugs mailing list
llvm-bugs@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/llvm-bugs