On Fri, Sep 25, 2015 at 2:33 PM, Ilia K <ki.s...@gmail.com> wrote: > oops.. > -lldb-...@cs.uiuc.edu > +lldb-dev@lists.llvm.org > > On Fri, Sep 25, 2015 at 2:30 PM, Hafiz Abid Qadeer <abidh....@gmail.com> > wrote: > >> Sounds reasonable to me. >> >> On Fri, Sep 25, 2015 at 8:02 AM, Ilia K <ki.s...@gmail.com> wrote: >> >>> Hi guys! >>> >>> I found the following things that can be simplified: >>> 1. Add CMIUtilString(std::string) ctor: >>> ``` >>> CMIUtilString(std::string().c_str()) -> CMIUtilString(std::string()) >>> ``` >>> Patch: http://reviews.llvm.org/D13158 >>> 2. Rename CMICmnBase::SetErrorDescriptionn to >>> CMICmnBase::SetErrorDescriptionFormat >>> 3. Allow to pass unformatted arguments (i.e. format string + tuple of >>> parameters) to CMICmnBase::SetErrorDescription: >>> ``` >>> SetErrorDescription(CMIUtilString::Format(MIRSRC(IDS_CMDFACTORY_ERR_INVALID_CMD_NAME), >>> vMiCmd.c_str())) >>> ``` >>> and then remove CMICmnBase::SetErrorDescriptionFormat. >>> 4. Allow to pass unformatted arguments to CMICmdBase::SetError: >>> ``` >>> SetError(CMIUtilString::Format(MIRSRC(IDS_CMD_ERR_OPTION_NOT_FOUND), >>> m_cmdData.strMiCmd.c_str(), m_constStrArgThread.c_str())); >>> ``` >>> >>> Thoughts? >>> >>> -- >>> - Ilia >>> >> >> > > > -- > - Ilia >
-- - Ilia
_______________________________________________ lldb-dev mailing list lldb-dev@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-dev