omjavaid added inline comments.

================
Comment at: 
lldb/source/Plugins/Process/Linux/NativeRegisterContextLinux_arm64.cpp:573
 
-  ::memcpy(dst, GetGPRBuffer(), GetGPRBufferSize());
-  dst += GetGPRBufferSize();
+  dst = AddSavedRegisters(dst, SavedRegistersKind::GPR, GetGPRBuffer(),
+                          GetGPRBufferSize());
----------------
I think we have lost some of code readability of ReadAllRegisterValues function 
by introducing AddSavedRegisters mechanism. It does remove some duplication of 
memcpy but it also introduces some differentiation between 
Read/WritellRegisterValues functions. I am inclined that we should put the 
memcpy into ReadAllRegisterValues to make it look similar to its Write 
counterpart. 


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D156687/new/

https://reviews.llvm.org/D156687

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to