mib added a comment. It's unfortunate that we're not able to determine easily if the stop is public or not, so I guess this is the best we could do for now.
We could however greatly reduce the amount of changes in the patch by having `select_most_relevant` default to `false` (or the `true` either way). Then, to improve readability, we would only need to add an inline comment before the argument (`GetSelectedFrame(/*select_most_relevant=*/true)`) like Jonas suggested. Other than that, this looks good to me :) ================ Comment at: lldb/include/lldb/Target/Process.h:2164 // false will avoid this behavior. + // If we are waiting to stop that will return control to the user, + // then we also want to run SelectMostRelevantFrame, which is controlled ---------------- typo I guess Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D148863/new/ https://reviews.llvm.org/D148863 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits