davrec added inline comments.
================ Comment at: clang/include/clang/AST/DeclTemplate.h:3427 +TemplateParameterList *getReplacedTemplateParameterList(Decl *D); + ---------------- davrec wrote: > I don't object with making this public, and I can see the argument for making > this its own function rather than a Decl method all things being equal, but > given that we already have `Decl::getDescribedTemplateParams`, I think that > # this should probably also go in Decl, > # a good comment is needed explaining the difference between the two (e.g. > that the `D` is the template/template-like decl itself, not a templated decl > as required by `getDescribedTemplateParams`, or whatever), and what happens > when it is called on a non-template decl, and > # it probably should be named just `getTemplateParams` or something that > suggests its difference with `getDescribedTemplateParams`. > On second thought this should definitely be a Decl method called `getTemplateParameters()`, since all it does is dispatches to the derived class's implementation of that. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D131858/new/ https://reviews.llvm.org/D131858 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits