avogelsgesang marked 4 inline comments as done. avogelsgesang added inline comments.
================ Comment at: lldb/source/Plugins/Language/CPlusPlus/Coroutines.cpp:19 -static ValueObjectSP GetCoroFramePtrFromHandle(ValueObject &valobj) { - ValueObjectSP valobj_sp(valobj.GetNonSyntheticValue()); +static uint64_t GetCoroFramePtrFromHandle(ValueObjectSP valobj_sp) { if (!valobj_sp) ---------------- hawkinsw wrote: > Do we want to return a `lldb::addr_t`? I know that they are likely the same, > but do we want it for consistency? > > I see (below) several instances where we are passing around "addresses" and > they are plain `uint64_t` so I am obviously being unhelpful. Sorry! changed to `lldb::addr_t` in this complete file Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D132815/new/ https://reviews.llvm.org/D132815 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits