JDevlieghere marked 3 inline comments as done. JDevlieghere added inline comments.
================ Comment at: lldb/source/Host/macosx/objcxx/HostInfoMacOSX.mm:534 + if (auto dyld_process = dyld_process_create_for_current_task()) { + if (auto snapshot = dyld_process_snapshot_create_for_process( + dyld_process, nullptr)) { ---------------- aprantl wrote: > ``` > auto *dyld_process = dyld_process_create_for_current_task()); > if (!dyld_process) > return; > ``` > ? We don't want to return, we want to fall through to the logic below the `#endif`. I guess I could pull it out into a helper function? ================ Comment at: lldb/source/Host/macosx/objcxx/HostInfoMacOSX.mm:562 + }); + return; + } ---------------- aprantl wrote: > is this redundant? No, if this succeeds we're done here. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D131110/new/ https://reviews.llvm.org/D131110 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits