mib accepted this revision.
mib added a comment.
This revision is now accepted and ready to land.

This is great! Thanks for taking care of this! LGTM!



================
Comment at: lldb/source/Plugins/Language/CPlusPlus/LibCxx.cpp:609
   } else {
-    ValueObjectSP size_mode(dataval_sp->GetChildAtIndexPath({1, 0, 0}));
-    if (!size_mode)
+    if (ValueObjectSP size_mode = short_sp->GetChildMemberWithName(
+            ConstString("__size_"), /*can_create=*/true)) {
----------------
Nit: In the if statement it's called `size_mode` but it the other branch (line 
`603`) it's called `size_member`. Would be nice to make it more consistent.


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D129490/new/

https://reviews.llvm.org/D129490

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to