kimanh marked an inline comment as not done.
kimanh added a comment.

Thanks once more for reviewing! If I should rename the variable (or anything 
else), let me know! Otherwise, could you help me to land this change (since I 
do not have committer rights)?



================
Comment at: lldb/source/Plugins/SymbolFile/DWARF/DebugNamesDWARFIndex.cpp:136
           continue;
         if (entry_or->getCUOffset() != cu_offset)
           continue;
----------------
jankratochvil wrote:
> It would be nice to reverse these two comparisons for `found_entry_for_cu` 
> but `getCUOffset()` is much more expensive. Just saying.
> 
Ah, yes, that's true. I could call it `found_variable_entry_for_cu` though?


Repository:
  rG LLVM Github Monorepo

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D106355/new/

https://reviews.llvm.org/D106355

_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to