mhorne added a comment. The FreeBSD API usage looks correct to me, but I can't comment on too much more than that. The code could benefit from fewer unnamed constants.
I should also note that it is my intention to merge the FreeBSD watchpoint patches into the 13.0 branch, in about a week's time. So your `__FreeBSD_version` checks will need to be updated after that point. ================ Comment at: lldb/source/Plugins/Process/Utility/NativeRegisterContextBreakWatchpoint_arm64.cpp:57 + control_value |= ((1 << size) - 1) << 5; + control_value |= (2 << 1) | 1; + ---------------- These magic numbers would be better with names. I see quite a few instances of checking/setting the enable bit, but it is not obvious what is being done unless you already understand the control register layout. CHANGES SINCE LAST ACTION https://reviews.llvm.org/D96548/new/ https://reviews.llvm.org/D96548 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits