Higuoxing added a comment. In D84008#2160426 <https://reviews.llvm.org/D84008#2160426>, @MaskRay wrote:
> The number of changed tests is large. Is it worth moving the > `IO.mapOptional("Length", Unit.Length);` change to a separate patch to make > the refactoring more focused? Thanks This patch is intended to make the length field be inferred when emitting the .debug_info section. If we move the `IO.mapOption("Length", Unit.Length);` change to a separate change, we might not be able to know when to infer the length? There are two visitors, `DumpVisitor` which is used to emit the .debug_info section and `DIEFixupVisitor` which is used to calculate the length field for us. Do you mean that we keep the `DIEFixupVisitor` class and remove the `DumpVisitor` class in this patch? Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D84008/new/ https://reviews.llvm.org/D84008 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits