teemperor accepted this revision. teemperor added a comment. This revision is now accepted and ready to land.
LGTM beside my inline comment about the function name. ================ Comment at: lldb/source/Symbol/ClangASTContext.cpp:2483 + type = cast<clang::AtomicType>(type)->getValueType(); + break; case clang::Type::Auto: ---------------- In this case I would rename it to something like `getUnderlyingType`, `unpackType`, `removeWrappingTypes` or something like that. We shouldn't have our own definition of 'desugar' that differs from Clang's definition. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D71262/new/ https://reviews.llvm.org/D71262 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits