jingham marked 4 inline comments as done.
jingham added inline comments.

================
Comment at: 
lldb/packages/Python/lldbsuite/test/functionalities/thread/step_out/TestThreadStepOut.py:136
+        (self.inferior_target, self.inferior_process, thread, bkpt) = 
lldbutil.run_to_source_breakpoint(
+            self, self.bkpt_string, self.main_file, only_one_thread = False)
 
----------------
aprantl wrote:
> If `self.bkpt_string` and `self.main_file` are only used here, I would find 
> this easier to read:
> 
> `ldbutil.run_to_source_breakpoint(self, 'break here', 
> lldb.SBFileSpec('main.cpp'), only_one_thread = False)`
self.main_file is only used here, I moved it.

self.bkpt_string is used to calculate the line number self.breakpoint, and then 
the source breakpoint we set in run_to_source_breakpoint is supposed to match 
that line.  So I think it is clearer to use the variable than to repeat the 
pattern twice.


Repository:
  rLLDB LLDB

CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D69453/new/

https://reviews.llvm.org/D69453



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to