delcypher added inline comments.
================ Comment at: llvm/utils/lit/lit/LitConfig.py:81 + @property + def killProcessAndChildrenIsSupported(self): + """ ---------------- Sorry to be pedantic but this (`LitConfig.killProcessAndChildrenIsSupported`) should be called `maxIndividualTestTimeIsSupported` to be consistent with the rest of `LitConfig`'s public interface. The name `killProcessAndChildrenIsSupported` is leaking implementation details. ================ Comment at: llvm/utils/lit/lit/util.py:426 +def killProcessAndChildrenIsSupported(llvm_config): + """ ---------------- I don't really like how we're now coupling this function with the `LitConfig` object just so we can print out the text `Found python psutil module`. Do we actually need to print out that message? If the tests don't rely on this I either suggest we remove this. Repository: rG LLVM Github Monorepo CHANGES SINCE LAST ACTION https://reviews.llvm.org/D64251/new/ https://reviews.llvm.org/D64251 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits