labath added inline comments.
================ Comment at: include/lldb/Target/ObjCLanguageRuntime.h:202 + static ObjCLanguageRuntime *GetObjCLanguageRuntime(Process &process) { + return llvm::cast_or_null<ObjCLanguageRuntime>( ---------------- xiaobai wrote: > labath wrote: > > compnerd wrote: > > > I think it would be nice to just call this `Get` (and we could have > > > equivalents in the other languages). It makes the uses less verbose and > > > repetitive. > > I like that idea. > I also like this idea. Would you mind if I did that in a follow up? You're introducing the function in this patch. What's the point in renaming it immediately after that? I can see how renaming GetCPPLanguageRuntime might be a good thing to do in a separate patch, but I don't see a reason to do that with this function CHANGES SINCE LAST ACTION https://reviews.llvm.org/D63052/new/ https://reviews.llvm.org/D63052 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits