aprantl accepted this revision.
aprantl added inline comments.
This revision is now accepted and ready to land.


================
Comment at: source/Plugins/SymbolFile/DWARF/DWARFDebugAbbrev.cpp:32
   dw_uleb128_t prev_abbr_code = 0;
-  DWARFEnumState state = DWARFEnumState::MoreItems;
-  while (state == DWARFEnumState::MoreItems) {
+  while (true) {
     llvm::Expected<DWARFEnumState> es =
----------------
Not being too familiar with the API I still find the control flow in this loop 
to be hard to follow. Is `offset_ptr` incremented by `extract()`?


================
Comment at: source/Plugins/SymbolFile/DWARF/DWARFDebugAbbrev.h:48
 
+  // Unit test accessor functions
+  uint32_t GetIndexOffset() const { return m_idx_offset; }
----------------
FYI I think the proper way to doxygenify this is:

```
/// Unit test accessor functions.
/// @{
 ...
/// @}
```


CHANGES SINCE LAST ACTION
  https://reviews.llvm.org/D62630/new/

https://reviews.llvm.org/D62630



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to