JDevlieghere marked 2 inline comments as done. JDevlieghere added inline comments. Herald added a subscriber: dexonsmith.
================ Comment at: lldb/include/lldb/Utility/ReproducerInstrumentation.h:679 + template <typename Result> const Result &RecordResult(const Result &r) { + UpdateBoundary(); + if (ShouldCapture()) { ---------------- Let's cast this or hide it behind a macro to prevent code duplication. ================ Comment at: lldb/unittests/Utility/ReproducerInstrumentationTest.cpp:552 +#if 0 + InstrumentedFoo* foo_ptr = bar.GetInstrumentedFooPtr(); +#endif ---------------- Oops, this should be removed. Repository: rLLDB LLDB CHANGES SINCE LAST ACTION https://reviews.llvm.org/D60178/new/ https://reviews.llvm.org/D60178 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org https://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits