eugene marked an inline comment as done.
eugene added inline comments.

================
Comment at: packages/Python/lldbsuite/test/tools/lldb-server/main.cpp:32-42
+static const char *const RETVAL_PREFIX = "retval:";
+static const char *const SLEEP_PREFIX = "sleep:";
+static const char *const STDERR_PREFIX = "stderr:";
+static const char *const SET_MESSAGE_PREFIX = "set-message:";
+static const char *const PRINT_MESSAGE_COMMAND = "print-message:";
+static const char *const GET_DATA_ADDRESS_PREFIX = "get-data-address-hex:";
+static const char *const GET_STACK_ADDRESS_COMMAND = "get-stack-address-hex:";
----------------
jingham wrote:
> This change seems a shame, the original was much easier to read.
Agree. But I think consistency is better than beauty in case of code formatting.


================
Comment at: packages/Python/lldbsuite/test/tools/lldb-server/main.cpp:62
 
-static void
-print_thread_id ()
-{
-       // Put in the right magic here for your platform to spit out the thread 
id (tid) that debugserver/lldb-gdbserver would see as a TID.
-       // Otherwise, let the else clause print out the unsupported text so 
that the unit test knows to skip verifying thread ids.
+static void print_thread_id() {
+// Put in the right magic here for your platform to spit out the thread id 
(tid)
----------------
jingham wrote:
> clang-format moved the initial { for functions into the function definition 
> line universally when it was run over the lldb sources.  If we want to revise 
> that decision, and go back to the initial function curly starting a line, 
> that would be fine by me, but I don't think we should do it piecemeal. 
> 
> Ditto for separating the return type & function name onto separate lines.  
> That was the way we did it originally, but the clang-format style that was 
> chosen for the reformatting undid that.  I much prefer the way you changed it 
> to here, but that's a decision we should make globally, not file by file.
Could you please elaborate. 
I just ran 'clang-format -style=file -i main.cpp' assuming that it will 
actually make the file complaint with the lldb's coding style by using top 
level .clang-format.


https://reviews.llvm.org/D30234



_______________________________________________
lldb-commits mailing list
lldb-commits@lists.llvm.org
http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits

Reply via email to