zturner added inline comments. ================ Comment at: source/Plugins/Process/minidump/MinidumpTypes.h:259 @@ +258,3 @@ +static_assert(sizeof(MinidumpSystemInfo) == MINIDUMP_SYSTEM_INFO_SIZE, "sizeof MinidumpSystemInfo is not correct!"); + +struct MinidumpMiscInfo ---------------- I think the `static_assert` is a good idea. Since this corresponds to an on disk format where the size of the structure is fixed and known, the static assert is a good idea. But the calculation is unnecessary I think. It's more readable if someone can just look at it and say "ok it has to be 32 bytes" or whatever, rather than doing this math in their head.
https://reviews.llvm.org/D23545 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits