labath accepted this revision. labath added a comment. This revision is now accepted and ready to land.
Looks good. Thank you for taking the time to add the tests. Please consider the comment below though. Do you have commit access? ================ Comment at: unittests/Core/ScalarTest.cpp:90 @@ +89,3 @@ + ASSERT_TRUE(s_scalar.ExtractBitfield(0, 0)); + ASSERT_EQ(0, memcmp(&a1, s_scalar.GetBytes(), sizeof(a1))); + ASSERT_TRUE(s_scalar.ExtractBitfield(len, 0)); ---------------- Is there a reason this couldn't be written as `ASSERT_EQ(a1, s_scalar.SLongLong())` ? If there isn't one, I think this would make the check more readable. http://reviews.llvm.org/D20355 _______________________________________________ lldb-commits mailing list lldb-commits@lists.llvm.org http://lists.llvm.org/cgi-bin/mailman/listinfo/lldb-commits