On Tue, 2015-06-09 at 21:00 -0500, Tang Yuantian-B29983 wrote: > Please see my replay inline. > ________________________________________ > From: Wood Scott-B07421 > Sent: Wednesday, June 10, 2015 6:28 AM > To: Tang Yuantian-B29983 > Cc: Wood Scott-B07421; linuxppc-dev@lists.ozlabs.org; > linux-ker...@vger.kernel.org; Zhao Chenhui-B35336; Tang Yuantian > Subject: Re: [PATCH v3] powerpc/cache: add cache flush operation for > various e500 > > On Tue, 2015-06-09 at 09:53 +0800, Yuantian.Tang@freescale.comwrote: > > From: Tang Yuantian <yuantian.t...@freescale.com> > > > > Various e500 core have different cache architecture, so they > > need different cache flush operations. Therefore, add a callback > > function cpu_flush_caches to the struct cpu_spec. The cache flush > > operation for the specific kind of e500 is selected at init time. > > The callback function will flush all caches inside the current cpu. > > > > Signed-off-by: Chenhui Zhao <chenhui.z...@freescale.com> > > Signed-off-by: Tang Yuantian <yuantian.t...@feescale.com> > > --- > > v3: > > - change all flush_caches to cpu_down_flush > > - replace whitespace with tab > [snip] > .cpu_setup = __setup_cpu_e500v2, > > .machine_check = machine_check_e500, > > .platform = "ppc8548", > > + .cpu_down_flush = cpu_down_flush_e500v2, > > It's still not lined up. I'm not a fan of the "line up all the =" > style, as it's a pain to maintain (and can be harder to read if the > "=" > is too far to the right), but mixing the two is worse. > > [Yuantian]: > I need more clear about this. > The only difference here is that my function puts ONE tab before "=" > and ONE white space after "="; > but the other functions in this structure use TWO tabs before "=". > Is that what you want?
The existing code aligns all the "=" characters (using whatever number of tabs before "=" are required to accomplish that). Yours doesn't. -Scott _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev