From: leroy > Le 20/01/2015 12:09, David Laight a écrit : > > From Christophe Leroy > >> Having a macro will help keep clear code. > > It might remove an #if but it doesn't really help. > > All it means is that anyone reading the code has to hunt for > > the definition before proceeding. > > > > Some comment about what (and why) the extra code is needed > > might help. > The main reason is because of patch 09/11 where we have to duplicate > this code. I prefer to just duplicate one line rather than duplicate the > whole code (especially because in v1 of the PATCHset, it was duplicated > twice): > > - DO_8xx_CPU15(r11, r10) > [...] > #ifdef CONFIG_MODULES > [...] > + DO_8xx_CPU15(r10, r11) > [...] > +#else > + mfspr r10, SPRN_SRR0 /* Get effective address of fault */ > + DO_8xx_CPU15(r11, r10) > > Is this approach wrong ?
I'd call it something that infers 'invalidate adjacent pages' and then mention that this is needed due to a cpu errata. David _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev