Christophe Leroy <christophe.le...@c-s.fr> wrote on 2014/09/19 15:57:56:

> +#define HAVE_ARCH_CSUM_ADD
> +static inline __wsum csum_add(__wsum csum, __wsum addend)
> +{
> +    __asm__("\n\
> +   addc %0,%0,%1 \n\
> +   addze %0,%0 \n\
> +   "
> +   : "=r" (csum)
> +   : "r" (addend), "0"(csum));

hmm, I wonder if not this is better written as:
: "+r" (csum): "r" (addend))

  Jocke
_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Reply via email to