On Tue,  9 Sep 2014 10:42:27 +0100
Aaron Tomlin <atom...@redhat.com> wrote:

> +void task_stack_end_magic(struct task_struct *tsk)
> +{
> +     unsigned long *stackend;
> +
> +     stackend = end_of_stack(tsk);
> +     *stackend = STACK_END_MAGIC;    /* for overflow detection */
> +}
> +

For clarity this should probably be called set_task_stack_end_magic().

And has this been tested on parisc and metag, which use STACK_GROWSUP ?
I can't see how end_of_stack() as it's defined now could work on those archs.


_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@lists.ozlabs.org
https://lists.ozlabs.org/listinfo/linuxppc-dev

Reply via email to