On 03/21/2014 04:24 PM, Viresh Kumar wrote: > On 21 March 2014 16:13, Gautham R Shenoy <e...@linux.vnet.ibm.com> wrote: >> On Fri, Mar 21, 2014 at 02:11:32PM +0530, Viresh Kumar wrote: > >>>> + pr_debug("PState id %d freq %d MHz\n", id, freq); >>>> + powernv_freqs[i].driver_data = i; >>> [...] >>>> +static int powernv_cpufreq_cpu_init(struct cpufreq_policy *policy) >>>> +{ >>>> + int base, i; >>>> + >>>> +#ifdef CONFIG_SMP >>> >>> What will break if you don't have this ifdef here? Without that as well >>> below code should work? > > Missed this one? >
Nothing will break, its just that the code size will be a tiny bit lesser on UP configs, that's all :-) Anyway, I think removing the ifdef improves the readability (and doesn't add any noticeable overhead on UP kernels), so let's get rid of it. Regards, Srivatsa S. Bhat >>>> + base = cpu_first_thread_sibling(policy->cpu); >>>> + >>>> + for (i = 0; i < threads_per_core; i++) >>>> + cpumask_set_cpu(base + i, policy->cpus); >>>> +#endif >>>> + policy->cpuinfo.transition_latency = 25000; >>>> + >>>> + policy->cur = powernv_freqs[0].frequency; >>>> + cpufreq_frequency_table_get_attr(powernv_freqs, policy->cpu); >>> _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev