On Thu, Sep 12, 2013 at 01:44:46PM -0500, Scott Wood wrote: > On Thu, 2013-09-12 at 15:13 +0800, Kevin Hao wrote: > > In the current kernel, the board files for p2041rdb, p3041ds, p4080ds, > > p5020ds, p5040ds, t4240qds and b4qds are almost the same except the > > machine name. So this introduces a cornet_generic machine to support > > all these boards to avoid the code duplication. > > > > Signed-off-by: Kevin Hao <haoke...@gmail.com> > > --- > > This patch is based on http://patchwork.ozlabs.org/patch/274390/ > > > > arch/powerpc/platforms/85xx/Kconfig | 10 ++++ > > arch/powerpc/platforms/85xx/Makefile | 8 +-- > > arch/powerpc/platforms/85xx/b4_qds.c | 97 > > -------------------------------- > > arch/powerpc/platforms/85xx/corenet_ds.c | 86 ++++++++++++++++++++++++++++ > > arch/powerpc/platforms/85xx/p2041_rdb.c | 87 ---------------------------- > > arch/powerpc/platforms/85xx/p3041_ds.c | 89 ----------------------------- > > arch/powerpc/platforms/85xx/p4080_ds.c | 87 ---------------------------- > > arch/powerpc/platforms/85xx/p5020_ds.c | 93 > > ------------------------------ > > arch/powerpc/platforms/85xx/p5040_ds.c | 84 --------------------------- > > arch/powerpc/platforms/85xx/t4240_qds.c | 93 > > ------------------------------ > > 10 files changed, 97 insertions(+), 637 deletions(-) > > delete mode 100644 arch/powerpc/platforms/85xx/b4_qds.c > > delete mode 100644 arch/powerpc/platforms/85xx/p2041_rdb.c > > delete mode 100644 arch/powerpc/platforms/85xx/p3041_ds.c > > delete mode 100644 arch/powerpc/platforms/85xx/p4080_ds.c > > delete mode 100644 arch/powerpc/platforms/85xx/p5020_ds.c > > delete mode 100644 arch/powerpc/platforms/85xx/p5040_ds.c > > delete mode 100644 arch/powerpc/platforms/85xx/t4240_qds.c > > Why not merge patch 2/2 with this?
OK. I will fold the patch 2 into this one. > > Did you use -M -C with git format-patch? For this case, using '-M -C' or not would generate the same patch. > > > diff --git a/arch/powerpc/platforms/85xx/Kconfig > > b/arch/powerpc/platforms/85xx/Kconfig > > config TQM85xx [...] > > bool > > + > > +config CORENET_GENERIC > > + bool > > Why do we need separate kconfig symbols for each board, if they all > select the same code? I thought it would be more obvious for the board support if we have a separate option for each board. We can also use this option for some board specific configuration if we have. Yes, it does seem a bit redundant. If you prefer I can drop these boards options. > > > +define_machine(corenet_generic) { > > + .name = "CORENET GENERIC", > > No allcaps please. How about "CORENET Generic"? BTW with these changes the file name "corenet_ds.c" seems not accurate anymore? How about change it to "corenet_generic.c"? Thanks, Kevin > > -Scott > > >
pgp0Gia7jSiSN.pgp
Description: PGP signature
_______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev