On Mon, 2012-09-17 at 12:58 +0100, Srinivas KANDAGATLA wrote: > From: Srinivas Kandagatla <srinivas.kandaga...@st.com> > > As follow-up to "dt: introduce of_get_child_by_name to get child node by > name." patch, This patch removes some of the code duplication in the > driver by replacing it with of_get_child_by_name instead. > > Signed-off-by: Srinivas Kandagatla <srinivas.kandaga...@st.com> > --- > arch/powerpc/platforms/powernv/opal.c | 6 +++--- > 1 files changed, 3 insertions(+), 3 deletions(-) > > diff --git a/arch/powerpc/platforms/powernv/opal.c > b/arch/powerpc/platforms/powernv/opal.c > index aaa0dba..fc7ae70 100644 > --- a/arch/powerpc/platforms/powernv/opal.c > +++ b/arch/powerpc/platforms/powernv/opal.c > @@ -294,9 +294,9 @@ static int __init opal_init(void) > consoles = of_node_get(opal_node); > > /* Register serial ports */ > - for_each_child_of_node(consoles, np) { > - if (strcmp(np->name, "serial")) > - continue; > + np = of_get_child_by_name(consoles, "serial"); > + if (np) { > + of_node_put(np); > of_platform_device_create(np, NULL, NULL);
You mustn't drop the reference until after you've finished with np, as you have written it the node could be freed before you call of_platform_device_create(). cheers _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev