On Fri, Jun 15, 2012 at 09:19:45PM +0800, Wanpeng Li wrote: > From: Wanpeng Li <l...@linux.vnet.ibm.com> > > Since there are five lists in LRU cache, the array nr in get_scan_count > should be: > > nr[0] = anon inactive pages to scan; nr[1] = anon active pages to scan > nr[2] = file inactive pages to scan; nr[3] = file active pages to scan > > Signed-off-by: Wanpeng Li <liwp.li...@gmail.com> > Acked-by: KOSAKI Motohiro <kosaki.motoh...@jp.fujitsu.com> > Acked-by: Minchan Kim <minc...@kernel.org> > Reviewed-by: Rik van Riel <r...@redhat.com> > > --- > mm/vmscan.c | 3 ++- > 1 file changed, 2 insertions(+), 1 deletion(-) > > diff --git a/mm/vmscan.c b/mm/vmscan.c > index eeb3bc9..ed823df 100644 > --- a/mm/vmscan.c > +++ b/mm/vmscan.c > @@ -1567,7 +1567,8 @@ static int vmscan_swappiness(struct scan_control *sc) > * by looking at the fraction of the pages scanned we did rotate back > * onto the active list instead of evict. > * > - * nr[0] = anon pages to scan; nr[1] = file pages to scan > + * nr[0] = anon inactive pages to scan; nr[1] = anon active pages to scan > + * nr[2] = file inactive pages to scan; nr[3] = file active pages to scan > */
Does including this in the comment have any merit in the first place? We never access nr[0] or nr[1] etc. anywhere with magic numbers. It's a local function with one callsite, the passed array is declared and accessed exclusively by what is defined in enum lru_list, where is the point in repeating the enum items?. I'd rather the next change to this comment would be its removal. _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev