On Wed, 2010-07-14 at 17:35 +0200, Segher Boessenkool wrote: > > V4: Fixed misspelling > > Any particular reason you fixed only one of the two > mispelings I pointed out? (device tree is two words, > not one).
Ahh, my fault. > > > + prop = of_find_property(node, "linux,devicetree-start", NULL); > > + if (prop) > > + prom_remove_property(node, prop); > > + > > + prop = of_find_property(node, "linux,devicetree-end", NULL); > > + if (prop) > > + prom_remove_property(node, prop); > > + > > + flat_dt_start = virt_to_phys(initial_boot_params); > > + flat_dt_end = virt_to_phys(initial_boot_params) > > + + initial_boot_params->totalsize; > > + prom_add_property(node, &flat_dt_start_prop); > > + prom_add_property(node, &flat_dt_end_prop); > > You could use one property instead of two; use addr+len > like every other property does. > > You also should use a better name for the property; is this > the previous kernel's device tree? Just "device-tree" makes > no sense, it is not pointing to "the" device tree for sure! > What about just one node called "flat-device-tree"? -Matthew _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev