On Wed, Jul 01, 2026 at 11:19:23AM +0530, Aneesh Kumar K.V (Arm) wrote: > ret in dma_direct_alloc() and dma_direct_alloc_pages() holds the returned > CPU mapping, not a generic return value. Rename it to cpu_addr and update > the remaining uses to match. > > This makes the allocation paths easier to follow and keeps the local naming > consistent with what the variable actually represents. > > Tested-by: Michael Kelley <[email protected]> > Tested-by: Mostafa Saleh <[email protected]> > Reviewed-by: Petr Tesarik <[email protected]> > Signed-off-by: Aneesh Kumar K.V (Arm) <[email protected]> > --- > kernel/dma/direct.c | 40 ++++++++++++++++++++-------------------- > 1 file changed, 20 insertions(+), 20 deletions(-)
Reviewed-by: Jason Gunthorpe <[email protected]> Jason
