On Fri, Jul 3, 2026 at 12:00 PM Mark Rutland <[email protected]> wrote:
> Bikeshedding below; sorry. > > I think the bigger problem is just that secure_computing() is a terrible > name that does not express the intended semantic -- it's not clear > whether "secure computing" means "seccomp permit the syscall" or > "seccomp is enabled and some special rules now apply" or something else > entirely. > > If we're changing the return type, it might be worth renaming the > function something like: > > seccomp_permits_syscall() Yeah that's way better, let's do this. (I also had problems with this function!!) Rusty Russel's API design manifesto tells us to do this: https://gist.github.com/mjball/9cd028ac793ae8b351df1379f1e721f9 Yours, Linus Walleij
