On 7/2/26 04:57, [email protected] wrote: > From: Wei Fang <[email protected]> > > Since phylink only passes valid speed values to mac_link_up, the switch > statement with its default fallback to SPEED_10 is unnecessary. Replace > it with a direct call to PCR_PSPEED_VAL(). Also update PCR_PSPEED_VAL() > to use FIELD_PREP() for proper field masking instead of an open-coded > shift. > > Signed-off-by: Wei Fang <[email protected]> Reviewed-by: Maxime Chevallier <[email protected]> Maxime
- [PATCH v2 net-next 00/14] net: enetc: cleanups and impro... wei . fang
- [PATCH v2 net-next 01/14] net: enetc: extract commo... wei . fang
- [PATCH v2 net-next 02/14] net: enetc: extract commo... wei . fang
- [PATCH v2 net-next 03/14] net: enetc: convert ndo_s... wei . fang
- [PATCH v2 net-next 05/14] net: enetc: use PCI devic... wei . fang
- [PATCH v2 net-next 04/14] net: enetc: improve MAFT ... wei . fang
- [PATCH v2 net-next 06/14] net: enetc: simplify enet... wei . fang
- Re: [PATCH v2 net-next 06/14] net: enetc: simpl... Maxime Chevallier
- [PATCH v2 net-next 07/14] net: enetc: differentiate... wei . fang
- Re: [PATCH v2 net-next 07/14] net: enetc: diffe... Maxime Chevallier
- [PATCH v2 net-next 08/14] net: enetc: remove invali... wei . fang
- Re: [PATCH v2 net-next 08/14] net: enetc: remov... Maxime Chevallier
- [PATCH v2 net-next 09/14] net: enetc: remove enetc4... wei . fang
- [PATCH v2 net-next 10/14] net: enetc: refactor SI V... wei . fang
- [PATCH v2 net-next 11/14] net: enetc: move enetc_se... wei . fang
- [PATCH v2 net-next 12/14] net: enetc: remove redund... wei . fang
- [PATCH v2 net-next 13/14] net: enetc: use alloc_eth... wei . fang
- [PATCH v2 net-next 14/14] net: enetc: use kzalloc_f... wei . fang
