On Thu, Oct 17, 2024 at 02:55:22PM -0700, Josh Poimboeuf wrote: > SYM_FUNC_START(__put_user_2) > check_range size=2 > ASM_STAC > -3: movw %ax,(%_ASM_CX) > +2: movw %ax,(%_ASM_CX) > xor %ecx,%ecx > ASM_CLAC > RET > SYM_FUNC_END(__put_user_2) > EXPORT_SYMBOL(__put_user_2)
This patch provides an opportunity to give these labels more meaningful names, so that future rearrangements do not require as much boilerplate. For example, we can rename this label 2: to .Luser_2 or something similar. -- Kiryl Shutsemau / Kirill A. Shutemov