On Jul 9, 2008, at 6:42 AM, Josh Boyer wrote:
On Wed, 2008-07-09 at 14:10 +1000, David Gibson wrote:
libfdt is supposed to easy to embed in projects all and sundry.
Often, it won't be practical to separate the embedded libfdt's
namespace from that of the surrounding project. Which means there
can
be namespace conflicts between even libfdt's internal/static
functions
and functions or macros coming from the surrounding project's headers
via libfdt_env.h.
This patch, therefore, renames a bunch of libfdt internal functions
and macros and makes a few other chances to reduce the chances of
namespace collisions with embedding projects. Specifically:
- Internal functions (even static ones) are now named _fdt_*()
- The type and (static) global for the error table in
fdt_strerror() gain an fdt_ prefix
- The unused macro PALIGN is removed
- The memeq and streq macros are removed and open-coded in the
users (they were only used once each)
- Other macros gain an FDT_ prefix
- To save some of the bulk from the previous change, an
FDT_TAGALIGN() macro is introduced, where FDT_TAGALIGN(x) ==
FDT_ALIGN(x, FDT_TAGSIZE)
Signed-off-by: David Gibson <[EMAIL PROTECTED]>
On a slightly unrelated note, are you planning to sync the in-kernel
dtc/libfdt version with the upstream version anytime soon?
I know jon put an -rc, not sure if he plans to pick up the slew of
patches for the next -rc or the next release, but it would be good to
resync the in-kernel version for 2.6.27.
- k
_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev