In the previous commit powerpc added PAGE_SIZE related config symbols using the generic names.
So there's no need to refer to them in the definition of PAGE_SIZE_LESS_THAN_64KB etc, the negative dependency on the generic symbol is sufficient (in this case !PAGE_SIZE_64KB). Signed-off-by: Michael Ellerman <m...@ellerman.id.au> --- arch/Kconfig | 2 -- 1 file changed, 2 deletions(-) diff --git a/arch/Kconfig b/arch/Kconfig index 31c4fdc4a4ba..d235c9089d17 100644 --- a/arch/Kconfig +++ b/arch/Kconfig @@ -1007,12 +1007,10 @@ config PAGE_SIZE_LESS_THAN_64KB depends on !IA64_PAGE_SIZE_64KB depends on !PAGE_SIZE_64KB depends on !PARISC_PAGE_SIZE_64KB - depends on !PPC_64K_PAGES depends on PAGE_SIZE_LESS_THAN_256KB config PAGE_SIZE_LESS_THAN_256KB def_bool y - depends on !PPC_256K_PAGES depends on !PAGE_SIZE_256KB # This allows to use a set of generic functions to determine mmap base -- 2.35.1