Hello, The most important change is the removal of support of OPAL flags required for P9 DD1. It provides a good cleanup of some complex routines.
Thanks, C. Changes since v1: - dropped the change on the allocation of the pages donated to the XIVE IC. Needs a retest on a specific system. - Took into account Greg's comments on flag removal. Cédric Le Goater (13): KVM: PPC: Book3S HV: XIVE: Show detailed configuration in debug output powerpc/xive: Rename XIVE_IRQ_NO_EOI to show its a flag powerpc/xive: Introduce XIVE_IPI_HW_IRQ powerpc/xive: Use cpu_to_node() instead of ibm,chip-id property powerpc/xive: Add a name to the IRQ domain powerpc/xive: Add a debug_show handler to the XIVE irq_domain powerpc: Increase NR_IRQS range to support more KVM guests powerpc/xive: Remove P9 DD1 flag XIVE_IRQ_FLAG_SHIFT_BUG powerpc/xive: Remove P9 DD1 flag XIVE_IRQ_FLAG_MASK_FW powerpc/xive: Remove P9 DD1 flag XIVE_IRQ_FLAG_EOI_FW powerpc/xive: Simplify xive_do_source_eoi() powerpc/xive: Improve error reporting of OPAL calls KVM: PPC: Book3S HV: XIVE: Add a comment regarding VP numbering arch/powerpc/include/asm/opal-api.h | 6 +- arch/powerpc/include/asm/xive.h | 8 +- arch/powerpc/kvm/book3s_xive.h | 13 ++ arch/powerpc/sysdev/xive/xive-internal.h | 7 +- arch/powerpc/kvm/book3s_xive.c | 134 +++++++------- arch/powerpc/kvm/book3s_xive_native.c | 24 ++- arch/powerpc/kvm/book3s_xive_template.c | 5 - arch/powerpc/sysdev/xive/common.c | 214 +++++++++++------------ arch/powerpc/sysdev/xive/native.c | 46 ++--- arch/powerpc/sysdev/xive/spapr.c | 8 +- arch/powerpc/Kconfig | 2 +- 11 files changed, 234 insertions(+), 233 deletions(-) -- 2.26.2