Hello Nathan, On Thu 23-01-20 09:56:10, Nathan Lynch wrote: > Libor Pechacek <lpecha...@suse.cz> writes: > > In KVM guests drmem structure is only zero initialized. Trying to > > manipulate DLPAR parameters results in a crash in this environment. > > I think this statement needs qualification. Unless I'm mistaken, this > happens only when you boot a guest without any hotpluggable memory > configured, and then try to add or remove memory.
Thanks for the review. The introductory statement can indeed be clearer. [...] > > diff --git a/arch/powerpc/platforms/pseries/hotplug-memory.c > > b/arch/powerpc/platforms/pseries/hotplug-memory.c > > index c126b94d1943..4ea6af002e27 100644 > > --- a/arch/powerpc/platforms/pseries/hotplug-memory.c > > +++ b/arch/powerpc/platforms/pseries/hotplug-memory.c > > @@ -236,9 +236,9 @@ static int get_lmb_range(u32 drc_index, int n_lmbs, > > if (!start) > > return -EINVAL; > > > > - end = &start[n_lmbs - 1]; > > + end = &start[n_lmbs]; > > > > - last_lmb = &drmem_info->lmbs[drmem_info->n_lmbs - 1]; > > + last_lmb = &drmem_info->lmbs[drmem_info->n_lmbs]; > > if (end > last_lmb) > > return -EINVAL; > > Is this not undefined behavior? I'd rather do this in a way that does > not involve forming out-of-bounds pointers. Well, this is a tough question for the case when drmem_info->lmbs was not allocated. Given that the array does not exist, what bounds are we talking about? My patch builds on the fact that NULL[0] is NULL and NULL < NULL is false. Talking about a pointer to one past the last element of an non-existent array is too much philosophy for me. For the case when drmem_info->lmbs is allocated, last_lmb is a pointer to one past the last element of the array as Michal mentioned. > Even if it's safe, naming that pointer "last_lmb" now actively hinders > understanding of the code; it should be named "limit" or something. Good catch. [...] > 1 file changed, 36 insertions(+), 7 deletions(-) > arch/powerpc/include/asm/drmem.h | 43 +++++++++++++++++++++++++++++++++------- > > modified arch/powerpc/include/asm/drmem.h > @@ -20,19 +20,48 @@ struct drmem_lmb { > > struct drmem_lmb_info { > struct drmem_lmb *lmbs; > - int n_lmbs; > + unsigned int n_lmbs; > u32 lmb_size; > }; > > extern struct drmem_lmb_info *drmem_info; > > -#define for_each_drmem_lmb_in_range(lmb, start, end) \ > - for ((lmb) = (start); (lmb) <= (end); (lmb)++) > +static inline bool drmem_present(void) > +{ > + return drmem_info->lmbs != NULL; > +} Yes, use of this test was also my first idea about the fix. > +static inline struct drmem_lmb *drmem_lmb_index(unsigned int index) > +{ > + if (!drmem_present()) > + return NULL; > > -#define for_each_drmem_lmb(lmb) \ > - for_each_drmem_lmb_in_range((lmb), \ > - &drmem_info->lmbs[0], \ > - &drmem_info->lmbs[drmem_info->n_lmbs - 1]) > + if (WARN_ON(index >= drmem_info->n_lmbs)) > + return NULL; Why is this WARN_ON needed? > + > + return &drmem_info->lmbs[index]; > +} > + > +static inline struct drmem_lmb *drmem_first_lmb(void) > +{ > + return drmem_lmb_index(0); > +} > + > +static inline struct drmem_lmb *drmem_last_lmb(void) > +{ > + if (!drmem_present()) > + return NULL; > + > + return drmem_lmb_index(drmem_info->n_lmbs - 1); Is the unsigned integer wraparound intended in drmem_info->n_lmbs == 0 case? > +} > + > +#define for_each_drmem_lmb(lmb) > \ > + for ((lmb) = drmem_first_lmb(); \ drmem_first_lmb() is essentially a call to drmem_info->lmbs(0). What happens if drmem_info->n_lmbs is zero and drmem_info->lmbs is not NULL? > + (lmb) != NULL && (lmb) <= drmem_last_lmb(); \ > + (lmb)++) > + > +#define for_each_drmem_lmb_in_range(lmb, start, end) \ > + for ((lmb) = (start); (lmb) <= (end); (lmb)++) > > /* > * The of_drconf_cell_v1 struct defines the layout of the LMB data > After all, I don't mind how the bug will be fixed. As you can see, my preference is towards simpler solutions. In my opinion your solution special-cased drmem_info->lmbs == NULL and opened the doorway to the combination of drmem_info->lmbs != NULL && !drmem_info->n_lmbs. Maybe the condition can never become true but the code should IMHO be robust enough to handle it. Thanks! Libor -- Libor Pechacek SUSE Labs Remember to have fun...