On Thu, May 16, 2019 at 04:03:27PM +0200, Jann Horn wrote: > On Thu, May 16, 2019 at 3:08 PM Christian Brauner <christ...@brauner.io> > wrote: > > On Wed, May 15, 2019 at 10:45:06AM -0700, Daniel Colascione wrote: > > > On Wed, May 15, 2019 at 3:04 AM Christian Brauner <christ...@brauner.io> > > > wrote: > > > > > > > > This adds the pidfd_open() syscall. It allows a caller to retrieve > > > > pollable > > > > pidfds for a process which did not get created via CLONE_PIDFD, i.e. > > > > for a > > > > process that is created via traditional fork()/clone() calls that is > > > > only > > > > referenced by a PID: > [...] > > > > +/** > > > > + * pidfd_open() - Open new pid file descriptor. > > > > + * > > > > + * @pid: pid for which to retrieve a pidfd > > > > + * @flags: flags to pass > > > > + * > > > > + * This creates a new pid file descriptor with the O_CLOEXEC flag set > > > > for > > > > + * the process identified by @pid. Currently, the process identified by > > > > + * @pid must be a thread-group leader. This restriction currently > > > > exists > > > > + * for all aspects of pidfds including pidfd creation (CLONE_PIDFD > > > > cannot > > > > + * be used with CLONE_THREAD) and pidfd polling (only supports thread > > > > group > > > > + * leaders). > > > > + * > > > > + * Return: On success, a cloexec pidfd is returned. > > > > + * On error, a negative errno number will be returned. > > > > + */ > > > > +SYSCALL_DEFINE2(pidfd_open, pid_t, pid, unsigned int, flags) > > > > +{ > [...] > > > > + if (pid <= 0) > > > > + return -EINVAL; > > > > > > WDYT of defining pid == 0 to mean "open myself"? > > > > I'm torn. It be a nice shortcut of course but pid being 0 is usually an > > indicator for child processes. So unless the getpid() before > > pidfd_open() is an issue I'd say let's leave it as is. If you really > > want the shortcut might -1 be better? > > Joining the bikeshed painting club: Please don't allow either 0 or -1 > as shortcut for "self". James Forshaw found an Android security bug a > while back (https://bugs.chromium.org/p/project-zero/issues/detail?id=727) > that passed a PID to getpidcon(), except that the PID was 0 > (placeholder for oneway binder transactions), and then the service > thought it was talking to itself. You could pick some other number and > provide a #define for that, but I think pidfd_open(getpid(), ...) > makes more sense.
Yes, I agree. I left it as is for v1, i.e. no shortcut; getpid() should do. Christian