Andrew Morton wrote: >> +static struct diu_hw dr = { >> + .mode = MFB_MODE1, >> + .reg_lock = __SPIN_LOCK_UNLOCKED(old_style_spin_init), >> +}; > > I'm not clear on what's supposed to happen with __SPIN_LOCK_UNLOCKED(). I > do know that its documentation is crap.
Yes, "__SPIN_LOCK_UNLOCKED(old_style_spin_init)" is wrong. We'll fix it. > static struct diu_hw dr = { > .mode = MFB_MODE1, > - .reg_lock = __SPIN_LOCK_UNLOCKED(old_style_spin_init), > + .reg_lock = __SPIN_LOCK_UNLOCKED(diu_hw.reg_lock), > }; Yes, this is better. Did you already make this change when you applied it to your -mm repo? > GFP_DMA implies GFP_ATOMIC, but it's appropriate for documentation purposes. So does that mean that "GFP_DMA | GFP_KERNEL" is always wrong? If so, this combination is used a lot in the kernel today. >> + if (virt) { >> + *phys = virt_to_phys(virt); >> + pr_debug("virt %p, phys=%llx\n", virt, (uint64_t) *phys); >> + memset(virt, 0, size); > > Could have used __GFP_ZERO, I guess. I had completely forgotten about __GFP_ZERO. Thanks. >> + virt = (void *) rh_alloc(&diu_ops.diu_rh_info, size, "DIU"); > > hm, I'd have expected checkpatch to whine about the space after the cast > there. Whatever. I thought a space after a cast is the right thing to do? > please take a look, and please use checkpatch on all future patches. Sorry, we forgot to run it again after our second version of the patch. >> +static void free_irq_local(int irq) >> +{ >> + struct diu *hw = dr.diu_reg; >> + >> + /* Disable all LCDC interrupt */ >> + out_be32(&(hw->int_mask), 0x1f); >> + >> + free_irq(irq, 0); >> +} > > and the free_irq() will go splat? Sorry, but I don't understand what's wrong with this code. We'll make the other changes you've suggested and repost. -- Timur Tabi Linux kernel developer at Freescale _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@ozlabs.org https://ozlabs.org/mailman/listinfo/linuxppc-dev