Oliver O'Halloran <ooh...@gmail.com> writes: > diff --git a/arch/powerpc/include/asm/pci-bridge.h > b/arch/powerpc/include/asm/pci-bridge.h > index aee4fcc24990..149053b7f481 100644 > --- a/arch/powerpc/include/asm/pci-bridge.h > +++ b/arch/powerpc/include/asm/pci-bridge.h > @@ -274,6 +274,8 @@ extern int pcibios_map_io_space(struct pci_bus *bus); > extern struct pci_controller *pci_find_hose_for_OF_device( > struct device_node* node); > > +extern struct pci_controller *pci_find_hose_for_domain(uint32_t domain_nr);
I know we use "hose" a lot in the PCI code, but it's a stupid name. Can we not introduce new usages? It returns a pci_controller so pci_find_controller_for_domain() ? cheers