On Wed, Nov 15, 2017 at 02:58:33PM +0530, Naveen N. Rao wrote: > > +int instr_is_link_branch(unsigned int instr) > > +{ > > + return (instr_is_branch_iform(instr) || instr_is_branch_bform(instr)) && > > + (instr & BRANCH_SET_LINK); > > +} > > + > > Nitpicking here, but since we're not considering the other branch forms, > perhaps this can be renamed to instr_is_link_relative_branch() (or maybe > instr_is_relative_branch_link()), just so we're clear :)
My understanding is that the absolute/relative bit isn't a "form", but rather a bit that can be set for either the b-form (conditional) or the i-form (unconditional). And the above function isn't checking the absolute bit, so it isn't necessarily a relative branch. Or did I miss something? -- Josh