Ram Pai <linux...@us.ibm.com> writes: + > +#define mm_set_pkey_is_allocated(mm, pkey) \ > + (mm_pkey_allocation_map(mm) & pkey_alloc_mask(pkey)) > +
> static inline bool mm_pkey_is_allocated(struct mm_struct *mm, int pkey) > { > - return (pkey == 0); > + /* a reserved key is never considered as 'explicitly allocated' */ > + return ((pkey < arch_max_pkey()) && > + !mm_set_pkey_is_reserved(mm, pkey) && > + mm_set_pkey_is_allocated(mm, pkey)); > } > that is confusing naming. what is mm_set_pkey_is_allocated()? . 'set' in that name is confusing. -aneesh