On Tue, 16 May 2017, Arnd Bergmann wrote: > On Tue, May 16, 2017 at 5:51 PM, Christoph Hellwig <h...@lst.de> wrote: > > Yes, that sounds useful to me as well. As you said it's an independent > > but somewhat related change. I can add it to my series, but I'll > > need a suggestions for a good and short name. That already was the > > hardest part for the setup side :) > > If we keep the unusual *_timer() naming (rather than timer_*() as hrtimer > has), we could use one of > > a) start_timer(struct timer_list *timer, unsigned long ms); > b) restart_timer(struct timer_list *timer, unsigned long ms); > c) mod_timer_ms(struct timer_list *timer, unsigned long ms); > mod_timer_sec(struct timer_list *timer, unsigned long sec);
Please make new functions prefixed with timer_ and get rid of that old interface completely. It's horrible. timer_init() timer_start(timer, ms, abs) timer_start_on(timer, ms, abs, cpu) timer_cancel(timer, sync) Is all what's required to make up a new milliseconds based interface. We really do not need all that mod/restart/ whatever variants. Where is the point of those? Thanks, tglx