On 2016/11/18 08:41PM, Michael Ellerman wrote: > "Naveen N. Rao" <naveen.n....@linux.vnet.ibm.com> writes: > > > - Introduce _GLOBAL_SYM() for global symbols in assembly. This helps > > reduce verbosity of assembly files. > > Unfortunately you've walked into a bit of mine field here :) > > In user space they use FUNC_START() to declare the start of a function, > and we should do the same. Anton added FUNC_START/END, but didn't quite > get around to converting everything, see 151f25112ff7 ("powerpc: define > FUNC_START/FUNC_END"). > > So what I'd like is all uses of _GLOBAL() to become FUNC_START(), and > then we can change _GLOBAL() to just define a global symbol.
Can't say I didn't get tempted to rename _GLOBAL() to _GLOBAL_FUNC() :D I'll convert the files I touch. > > We can probably decouple that from most of this series though, as I > mentioned in my other reply, just by using _ASM_NOKPROBE_SYMBOL(). Sure. Thanks! - Naveen