Hi Zhao Qiang, On Wed, Jul 06, 2016 at 02:01:38PM +0800, Zhao Qiang wrote: > The codes of qe_ic init from a variety of platforms are redundant, > merge them to a common function and put it to irqchip/qe_ic.c > > For non-p1021_mds mpc85xx_mds boards, use "qe_ic_init(np, 0, > qe_ic_cascade_low_mpic, qe_ic_cascade_high_mpic);" instead of > "qe_ic_init(np, 0, qe_ic_cascade_muxed_mpic, NULL);". > > qe_ic_cascade_muxed_mpic was used for boards has the same interrupt > number for low interrupt and high interrupt, qe_ic_init has checked > if "low interrupt == high interrupt" > > Signed-off-by: Zhao Qiang <qiang.z...@nxp.com> > --- > Changes for v2: > - modify subject and commit msg > - add check for qeic by type > > arch/powerpc/platforms/83xx/misc.c | 15 --------------- > arch/powerpc/platforms/85xx/corenet_generic.c | 9 --------- > arch/powerpc/platforms/85xx/mpc85xx_mds.c | 14 -------------- > arch/powerpc/platforms/85xx/mpc85xx_rdb.c | 16 ---------------- > arch/powerpc/platforms/85xx/twr_p102x.c | 14 -------------- > drivers/irqchip/qe_ic.c | 16 ++++++++++++++++ > 6 files changed, 16 insertions(+), 68 deletions(-)
Hmmm, I seem to be missing the patch moving qe_ic.c into drivers/irqchip/ ... :-/ Please resend with it attached. Also, while we're here, please follow the file naming convention inside the drivers/irqchip/ directory. Something like drivers/irqchip/irq-qeic.c thx, Jason. _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev