Michael Ellerman <m...@ellerman.id.au> writes: > Commit 74701d5947a6 "powerpc/mm: Rename function to indicate we are > allocating fragments" renamed page_table_free() to pte_fragment_free(). > One occurrence was mistyped as pte_fragment_fre(). > > This only breaks the nohash 4K page build, which is not the default or > enabled in any defconfig.
Can you share the .config. I will add it to the build test. > > Fixes: 74701d5947a6 ("powerpc/mm: Rename function to indicate we are > allocating fragments") > Signed-off-by: Michael Ellerman <m...@ellerman.id.au> Reviewed-by: Aneesh Kumar K.V <aneesh.ku...@linux.vnet.ibm.com> > --- > arch/powerpc/include/asm/nohash/64/pgalloc.h | 2 +- > 1 file changed, 1 insertion(+), 1 deletion(-) > > diff --git a/arch/powerpc/include/asm/nohash/64/pgalloc.h > b/arch/powerpc/include/asm/nohash/64/pgalloc.h > index 0c12a3bfe2ab..069369f6414b 100644 > --- a/arch/powerpc/include/asm/nohash/64/pgalloc.h > +++ b/arch/powerpc/include/asm/nohash/64/pgalloc.h > @@ -172,7 +172,7 @@ static inline pgtable_t pte_alloc_one(struct mm_struct > *mm, > > static inline void pte_free_kernel(struct mm_struct *mm, pte_t *pte) > { > - pte_fragment_fre((unsigned long *)pte, 1); > + pte_fragment_free((unsigned long *)pte, 1); > } > > static inline void pte_free(struct mm_struct *mm, pgtable_t ptepage) > -- > 2.5.0 _______________________________________________ Linuxppc-dev mailing list Linuxppc-dev@lists.ozlabs.org https://lists.ozlabs.org/listinfo/linuxppc-dev