I just noticed this of_iomap() helper thing we have in prom_parse.c
nowadays.

It's a bit confusing as "iomap" is generally what we use to name the new
iomap interface (ioport_map, pci_iomap, ...) and that requires
-different- accessors than memory obtained from ioremap.

This I think this needs to be changed.

We should call it of_ioremap() or of_map_resource() and if we want an
of_iomap(), it should provide an iomap token, not an ioremap address
(they look the same on powerpc, but they shouldn't be mixed up).

Ben.


_______________________________________________
Linuxppc-dev mailing list
Linuxppc-dev@ozlabs.org
https://ozlabs.org/mailman/listinfo/linuxppc-dev

Reply via email to