Hello.

On 09/27/2013 02:28 PM, Robert Baldyga wrote:

This patch add missing error check in ffs_func_bind() function, after
ffs_do_descs() funcion call for hs descriptors. Without this check it's

   s/funcion/function/.
   Perhaps it's worth expanding "hs" to "high speed" for clarity?

possible that the module will try dereference incorrect pointer.

Signed-off-by: Robert Baldyga <r.bald...@samsung.com>
---
  drivers/usb/gadget/f_fs.c |    3 +++
  1 file changed, 3 insertions(+)

diff --git a/drivers/usb/gadget/f_fs.c b/drivers/usb/gadget/f_fs.c
index 1a66c5b..fe7d532 100644
--- a/drivers/usb/gadget/f_fs.c
+++ b/drivers/usb/gadget/f_fs.c
@@ -2264,7 +2264,10 @@ static int ffs_func_bind(struct usb_configuration *c,
                                   data->raw_descs + ret,
                                   (sizeof data->raw_descs) - ret,
                                   __ffs_func_bind_do_descs, func);
+               if (unlikely(ret < 0))
+                       goto error;
        }
+       


   Why add second empty line here?

        /*
         * Now handle interface numbers allocation and interface and

WBR, Sergei

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to