From: Kurt Kanzenbach <ly80t...@cip.cs.fau.de>

In each if-else case "return" is called. This is why
these if-else-statements are useless. Removing them
improves understanding and readability.

Signed-off-by: Kurt Kanzenbach <ly80t...@cip.cs.fau.de>
Signed-off-by: Stefan Reif <ke42c...@cip.cs.fau.de>
---
 drivers/staging/usbip/stub_main.c | 26 +++++++++++++-------------
 1 file changed, 13 insertions(+), 13 deletions(-)

diff --git a/drivers/staging/usbip/stub_main.c 
b/drivers/staging/usbip/stub_main.c
index 705a9e5..629bfcb 100644
--- a/drivers/staging/usbip/stub_main.c
+++ b/drivers/staging/usbip/stub_main.c
@@ -167,22 +167,22 @@ static ssize_t store_match_busid(struct device_driver 
*dev, const char *buf,
        strncpy(busid, buf + 4, BUSID_SIZE);
 
        if (!strncmp(buf, "add ", 4)) {
-               if (add_match_busid(busid) < 0) {
+               if (add_match_busid(busid) < 0)
                        return -ENOMEM;
-               } else {
-                       pr_debug("add busid %s\n", busid);
-                       return count;
-               }
-       } else if (!strncmp(buf, "del ", 4)) {
-               if (del_match_busid(busid) < 0) {
+
+               pr_debug("add busid %s\n", busid);
+               return count;
+       }
+
+       if (!strncmp(buf, "del ", 4)) {
+               if (del_match_busid(busid) < 0)
                        return -ENODEV;
-               } else {
-                       pr_debug("del busid %s\n", busid);
-                       return count;
-               }
-       } else {
-               return -EINVAL;
+
+               pr_debug("del busid %s\n", busid);
+               return count;
        }
+
+       return -EINVAL;
 }
 static DRIVER_ATTR(match_busid, S_IRUSR | S_IWUSR, show_match_busid,
                   store_match_busid);
-- 
1.8.1

--
To unsubscribe from this list: send the line "unsubscribe linux-usb" in
the body of a message to majord...@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html

Reply via email to